Lessons Learned:
RIP Unicast updates – one reason you might want to use
unicast updates is to make sure the other devices on the specific segment would
not be able to receive routing control plane updates.
Technically this could be considered a security feature of the
routing protocol – not using multicast of broadcasts. Instead only define the
unicast neighbors of where you want to multicast neighbors of where you want
the updated to be sent.
The disadvantage is that we would need to keep track of all the
routers that are running the protocol.
Configurations /
implementations of Unicasts
On router 1:
R1(config)#router rip
R1(config-router)#neighbor 192.168.1.3
R1(config-router)#passive-interface fastEthernet 0/0
Note: the passive
interface command will stop the broadcast or multicast updates but still allow
the unicast updates.
R1#sh run | s router rip
router rip
version 2passive-interface FastEthernet0/0
network 192.168.1.0
neighbor 192.168.1.3
no auto-summary
R1#
---------------------------------------------------------------------
R1#sh run | s router rip
router rip
version 2
passive-interface
FastEthernet0/0
network 192.168.1.0
neighbor 192.168.1.1
no auto-summary
R1#
*Mar 1 00:27:14.807: RIP: sending v2 update to
192.168.1.3 via FastEthernet0/0 (192.168.1.1)
*Mar 1 00:27:14.807: RIP: build update entries -
suppressing null update
Note: We now see the updates going to the unicast IP
address and not the broadcast or multicast address.
No comments:
Post a Comment