Lessons Learned:
EIGRP Default Routing
EIGRP supports
default routing in two ways
Candidate default network
--IP default-network (network)
Native advertisement of a 0.0.0.0/0 prefix
Default-information command in EIGRP does not behave the
same as other protocols
The default information command in EIGRP simply controls whether the route will
accept a default route to whether it can continue to propagate a default
route on….
Example:
Under the EIGRP process if you specify “no default-information”, it means the router will not accept an
advertisement of a default route.
If we say “no
default-information out” it means
that if the router learns a default route from someone else, you will not
continue to propagate it on.
IP Default-Network
Originally came from IGRP
Candidate default network is backwards compatible with IGRP
-IGRP does not support the advertisement of 0.0.0.0/0
Default network must
be…
-Dynamically learned through EIGRP -Not directly connected
-Classful Network
Limited application due to these restrictions.
Topology:
We can send a default route in via redistribution
EX: on the BB1 router
– let’s been RIP with it and the Edge rtr.
BB1 Router:
router rip
version 2
network 11.0.0.0
network 20.0.0.0
network 30.0.0.0
network 192.168.1.0
no auto-summary
EDGE RTR
router eigrp 500
network 192.168.1.0
network 192.168.2.0
no auto-summary
!
router rip
version 2
network 192.168.1.0
no auto-summary
!
Now on the edge router we would need to do mutual redistribution:
EDGE-RTR(config)#router rip
EDGE-RTR(config-router)#redistribute eigrp 1 metric 1
EDGE-RTR(config-router)#exit
EDGE-RTR(config)#router eigrp 500
EDGE-RTR(config-router)#redistribute rip
EDGE-RTR(config-router)#redistribute rip metric 1 1 1 1 1
Now if we sh ip route
on the edge router we have the learned RIP routes.
EDGE-RTR#sh ip route rip
20.0.0.0/24 is
subnetted, 1 subnets
R 20.20.20.0
[120/1] via 192.168.1.10, 00:00:23, FastEthernet0/0
11.0.0.0/24 is subnetted,
1 subnets
R 11.11.11.0
[120/1] via 192.168.1.10, 00:00:23, FastEthernet0/0
30.0.0.0/24 is
subnetted, 1 subnets
R 30.30.30.0
[120/1] via 192.168.1.10, 00:00:23, FastEthernet0/0
EDGE-RTR#
I can now Tag one of these route as the default route
(config)#ip default-network 30.30.30.0
This will have the same effect as a default route to the done
stream neighbors.
This is the same as advertising a Zero route in EIGRP
So in the BB1 router :
(config)#ip default-network 30.30.30.0
Gateway of last
resort is 192.168.1.10 to network 0.0.0.0
20.0.0.0/24 is
subnetted, 1 subnets
R 20.20.20.0
[120/1] via 192.168.1.10, 00:00:21, FastEthernet0/0
10.0.0.0/24 is
subnetted, 2 subnets
D 10.2.1.0
[90/158720] via 192.168.2.3, 00:11:54, FastEthernet0/1
D 10.1.1.0
[90/158720] via 192.168.2.3, 00:11:54, FastEthernet0/1
11.0.0.0/24 is
subnetted, 1 subnets
R 11.11.11.0
[120/1] via 192.168.1.10, 00:00:21, FastEthernet0/0
C 192.168.1.0/24 is
directly connected, FastEthernet0/0
C 192.168.2.0/24 is
directly connected, FastEthernet0/1
D 192.168.3.0/24
[90/30720] via 192.168.2.3, 00:11:56, FastEthernet0/1
[90/30720] via 192.168.2.2, 00:11:56, FastEthernet0/1
30.0.0.0/8 is
variably subnetted, 2 subnets, 2 masks
R 30.30.30.0/24
[120/1] via 192.168.1.10, 00:00:23, FastEthernet0/0
S 30.0.0.0/8
[1/0] via 30.30.30.0
R* 0.0.0.0/0 [120/1] via 192.168.1.10,
00:00:14, FastEthernet0/0
EDGE-RTR#
This will propagate to all downstream routers, with each
router setting its next Hop as the default until it reached the BB1 router.
==============================================
Native Default
Advertisement
Native 0.0.0.0/0 network can be advertised via..
Static default route to an interface + network 0.0.0.0 under
EIGRP process.
Redistribution from static or another protocol
Summarization
All routers are running EIGRP process 500
All interface are participating in EIGRP
BB1’s interfaces:
BB1#sh ip int brief
FastEthernet0/0
192.168.1.10
Loopback1 11.11.11.1
Loopback2
20.20.20.1
Loopback3
30.30.30.1
Default route on BB2:
Gateway of last resort is not set
First:
On the EDGE Router let’s configure a static default route
and point it to interface fa0/0 towards network 30.30.30.0
Then under the EIGRP process we just need configure need to
say redistribute static
Result on BB2:
Gateway of last resort is 192.168.3.3 to network 0.0.0.0
D*EX 0.0.0.0/0 [170/33280] via 192.168.3.3, 00:00:05, FastEthernet0/0
BB2#
The only problem is now the route shows up as and External
route.
OR
We can set the default route to a next hop value rather just
an interface.
Remove the static: ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
30.30.30.1
Replace with: ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 - Just
the interface.
Also remove the redistributed route under the process and
then advertise the network 0.0.0.0 into EIGRP.
This should advertise a default network to all downstream
routers out the FA0/0 interface of the Edge RTR1.
Ex:
router eigrp 500
network 0.0.0.0
no auto-summary
Now because we’re not
redistributing the route still shows as the candidate default but it’s now
an internal route.
Gateway of last resort is 192.168.3.3 to network 0.0.0.0
D* 0.0.0.0/0
[90/33280] via 192.168.3.3, 00:01:15, FastEthernet0/0
BB2#
The only time this will really matter is if you have
multiple default routes. One that is an internal route and one that is an
external route. you would always prefer
the internal route based on the AD.
No comments:
Post a Comment